CVE-2019-11358 jQuery Vulnerability in NetApp Products

circle-info NetApp will continue to update this advisory as additional information becomes available.
This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp regarding Full Support products and versions.

The email subscription feature has been temporarily disabled.

Summary

Multiple NetApp products incorporate jQuery. Versions of jQuery prior to 3.4.0 are susceptible to a vulnerability which when successfully exploited could lead to disclosure of sensitive information or addition or modification of data.

Impact

Successful exploitation of this vulnerability could lead to disclosure of sensitive information or addition or modification of data.

Vulnerability Scoring Details

CVE Score Vector
CVE-2019-11358 6.1 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation and Public Announcements

NetApp is aware of public discussion of this vulnerability.

Affected Products

  • NetApp Cloud Backup (formerly AltaVault)
  • NetApp Cloud Backup OST Plug-in (formerly AltaVault OST Plug-in)
  • OnCommand System Manager 3.x
  • SnapCenter

Products Not Affected

  • 7-Mode Transition Tool
  • AFF Baseboard Management Controller (BMC) - A700s
  • Active IQ Unified Manager for Linux
  • Active IQ Unified Manager for Microsoft Windows
  • Active IQ Unified Manager for VMware vSphere
  • Active IQ mobile app
  • Astra Trident
  • Brocade Fabric Operating System Firmware
  • Cloud Insights Storage Workload Security Agent
  • E-Series SANtricity OS Controller Software 11.x
  • E-Series SANtricity Unified Manager and Web Services Proxy
  • Element HealthTools
  • Element Plug-in for vCenter Server
  • FAS/AFF BIOS - 8300/8700/A400/C400
  • FAS/AFF Baseboard Management Controller (BMC) - C190/A150/A220/FAS2720/FAS2750
  • Host Utilities - SAN for Linux
  • Host Utilities - SAN for Windows
  • IOM6 SAS Disk Shelf Firmware
  • MetroCluster Tiebreaker for clustered Data ONTAP
  • NetApp BlueXP
  • NetApp Converged Systems Advisor Agent
  • NetApp E-Series Performance Analyzer
  • NetApp HCI Baseboard Management Controller (BMC) - H300S/H500S/H700S/H410S
  • NetApp HCI Compute Node (Bootstrap OS)
  • NetApp HCI Compute Node BIOS
  • NetApp Manageability SDK
  • NetApp NFS Plug-in for VMware VAAI
  • NetApp ONTAP PowerShell Toolkit (PSTK)
  • NetApp SMI-S Provider
  • NetApp SolidFire & HCI Management Node
  • NetApp SolidFire & HCI Storage Node (Element Software)
  • NetApp SolidFire Plug-in for vRealize Orchestrator (SolidFire vRO)
  • NetApp VASA Provider for Clustered Data ONTAP 9.7 and above
  • ONTAP 9 (formerly Clustered Data ONTAP)
  • ONTAP Antivirus Connector
  • ONTAP Select Deploy administration utility
  • OnCommand Insight
  • OnCommand Workflow Automation
  • SANtricity Unified Manager
  • Single Mailbox Recovery
  • Snap Creator Framework
  • SnapCenter Plug-in for VMware vSphere/BlueXP backup and Recovery for Virtual Machine
  • SnapManager for Hyper-V
  • SolidFire Storage Replication Adapter
  • Storage Replication Adapter for Clustered Data ONTAP for VMware vSphere 9.7 and above
  • StorageGRID (formerly StorageGRID Webscale)
  • StorageGRID Baseboard Management Controller (BMC)
  • System Manager 9.x

Software Versions and Fixes

NetApp's currently available patches are listed below.


Product First Fixed in Release
NetApp Cloud Backup (formerly AltaVault) NetApp Cloud Backup (formerly AltaVault) has no plans to address this vulnerability. See the EOA announcement for more information.
NetApp Cloud Backup OST Plug-in (formerly AltaVault OST Plug-in) NetApp Cloud Backup OST Plug-in (formerly AltaVault OST Plug-in) has no plans to address this vulnerability. See the EOA announcement for more information.
OnCommand System Manager 3.x OnCommand System Manager 3.x has no plans to address this vulnerability. See the EOA announcement for more information.
SnapCenter https://mysupport.netapp.com/site/products/all/details/snapcenter/downloads-tab/download/62018/4.4

Workarounds

None at this time.

Obtaining Software Fixes

Software fixes will be made available through the NetApp Support website in the Software Download section.

https://mysupport.netapp.com/site/downloads/

Customers who do not have access to the Support website should contact Technical Support at the number below to obtain the patches.

Contact Information

Check http://mysupport.netapp.com for further updates.
For questions, contact NetApp at:

Technical Support
mysupport.netapp.com
1 888 4 NETAPP (1 888 463 8277) (U.S. and Canada)
+00 800 44 638277 (EMEA/Europe)
+800 800 80 800 (Asia/Pacific)

Status of This Notice

Interim.

NetApp will continue to update this advisory as additional information becomes available.

This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp regarding Full Support products and versions.

This advisory is posted at the following link:
https://security.netapp.com/advisory/NTAP-20190919-0001

Revision History

Revision # Date Comments
1.0 20190919 Initial Public Release
2.0 20191001 Active IQ Unified Manager (formerly OnCommand Unified Manager) for Linux 7.3 and above, Active IQ Unified Manager (formerly OnCommand Unified Manager) for VMware vSphere 9.5 and above, and Active IQ Unified Manager (formerly OnCommand Unified Manager) for Windows 7.3 and above moved to Products Not Affected
3.0 20191022 NetApp E-Series Performance Analyzer moved to Products Not Affected
4.0 20191127 NetApp SMI-S Provider moved to Products Not Affected
5.0 20200120 OnCommand System Manager 9.x moved to Products Not Affected
6.0 20200327 Active IQ Performance Analytics Services added to Software Versions and Fixes
7.0 20200417 NetApp Converged Systems Advisor Agent moved to Products Not Affected
8.0 20200708 OnCommand System Manager 3.x moved to Affected Products
9.0 20200910 OnCommand Insight moved to Products Not Affected
10.0 20201204 SnapCenter added to Software Versions and Fixes
11.0 20210104 OnCommand System Manager 3.x moved to Won't Fix status
12.0 20220106 NetApp Cloud Backup (formerly AltaVault) moved to Won't Fix status
13.0 20240102 NetApp Cloud Backup OST Plug-in (formerly AltaVault OST Plug-in) moved to Won't Fix status

This document is provided solely for informational purposes. All information is based upon NetApp’s current knowledge and understanding of the hardware and software products tested by NetApp, and the methodology and assumptions used by NetApp. NetApp is not responsible for any errors or omissions that may be contained herein, and no warranty, representation, or other legal commitment or obligation is being provided by NetApp. © 2022 NetApp, Inc. All rights reserved. No portions of this document may be reproduced without prior written consent of NetApp, Inc.