January 2018 Java Platform Standard Edition Vulnerabilities in NetApp Products

circle-check-alt This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

Summary

Multiple NetApp products incorporate the Oracle Java Platform, Standard Edition (Java SE) software libraries. Java SE (JDK and JRE) versions through 6u171, 7u161, 8u152, and 9.0.1 are susceptible to multiple vulnerabilities that could lead to a takeover of Java, a partial denial of service (DoS) of Java, or to the unauthorized reading or modification of a subset or all of the data accessible to the Java process.

Impact

Successful exploitation of these vulnerabilities could lead to a takeover of Java, a partial denial of service (DoS) of Java, or to the unauthorized reading or modification of a subset or all of the data accessible to the Java process.

Vulnerability Scoring Details

CVE Score Vector
CVE-2018-2579 3.7 (LOW) CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
CVE-2018-2581 4.7 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
CVE-2018-2582 6.5 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
CVE-2018-2588 4.3 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVE-2018-2599 4.8 (MEDIUM) CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
CVE-2018-2602 4.5 (MEDIUM) CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
CVE-2018-2603 5.3 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2018-2618 5.9 (MEDIUM) CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
CVE-2018-2627 7.5 (HIGH) CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
CVE-2018-2629 5.3 (MEDIUM) CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
CVE-2018-2633 8.3 (HIGH) CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
CVE-2018-2634 6.8 (MEDIUM) CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
CVE-2018-2637 7.4 (HIGH) CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
CVE-2018-2638 8.3 (HIGH) CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
CVE-2018-2639 8.3 (HIGH) CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
CVE-2018-2641 6.1 (MEDIUM) CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N
CVE-2018-2657 5.3 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2018-2663 4.3 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
CVE-2018-2675 3.7 (LOW) CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
CVE-2018-2677 4.3 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
CVE-2018-2678 4.3 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Exploitation and Public Announcements

NetApp is aware of public discussion of this vulnerability.

References

Affected Products

  • Active IQ Unified Manager (formerly OnCommand Unified Manager) for VMware vSphere 9.5 and above
  • Active IQ Unified Manager (formerly OnCommand Unified Manager) for Windows 7.3 and above
  • E-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM))
  • E-Series SANtricity Management Plug-ins (VMware SRA)
  • E-Series SANtricity Management Plug-ins (VMware VASA (Windows))
  • E-Series SANtricity Management Plug-ins (VMware vCenter (Linux))
  • E-Series SANtricity Management Plug-ins (VMware vCenter)
  • E-Series SANtricity OS Controller Software 11.x
  • E-Series SANtricity Storage Manager
  • E-Series SANtricity Web Services (REST API) for Web Services Proxy
  • NetApp Cloud Backup (formerly AltaVault)
  • NetApp Plug-in for Symantec NetBackup
  • NetApp SANtricity Cloud Connector
  • NetApp VASA Provider for Clustered Data ONTAP 6.x
  • NetApp VASA Provider for Clustered Data ONTAP 7.2 and above
  • OnCommand Insight
  • OnCommand Shift
  • OnCommand Unified Manager for 7-Mode (core package)
  • OnCommand Workflow Automation
  • SnapManager for Oracle
  • SnapManager for SAP
  • Storage Replication Adapter for Clustered Data ONTAP for VMware vSphere 7.2 and above
  • Storage Replication Adapter for Clustered Data ONTAP for Windows 7.2 and above
  • StorageGRID (formerly StorageGRID Webscale)
  • StorageGRID9 (9.x and prior)
  • Virtual Storage Console for VMware vSphere 6.x
  • Virtual Storage Console for VMware vSphere 7.2 and above

Products Not Affected

  • 7-Mode Transition Tool
  • ATTO FibreBridge - 6500N
  • Active IQ Unified Manager (formerly OnCommand Unified Manager) for Linux 7.3 and above
  • Brocade Fabric Operating System Firmware
  • Brocade Network Advisor Software
  • Clustered Data ONTAP
  • Clustered Data ONTAP Antivirus Connector
  • Data ONTAP operating in 7-Mode
  • Element Plug-in for vCenter Server
  • FAS/AFF BIOS
  • Host Utilities - SAN for Linux
  • Host Utilities - SAN for Windows
  • MetroCluster Tiebreaker for clustered Data ONTAP
  • NetApp Cloud Backup OST Plug-in (formerly AltaVault OST Plug-in)
  • NetApp Converged Systems Advisor Agent
  • NetApp HCI Compute Node (Bootstrap OS)
  • NetApp Manageability SDK
  • NetApp NFS Plug-in for VMware VAAI
  • NetApp SANtricity SMI-S Provider
  • NetApp SMI-S Provider
  • NetApp Service Level Manager
  • NetApp SolidFire & HCI Storage Node (Element Software)
  • NetApp Storage Encryption
  • ONTAP Select Deploy administration utility
  • OnCommand API Services
  • OnCommand Cloud Manager
  • OnCommand System Manager 9.x
  • Open Systems SnapVault Agent
  • RAID Controller CTS2600 Legacy Engenio
  • Service Processor
  • Single Mailbox Recovery
  • Snap Creator Framework
  • SnapCenter
  • SnapDrive for Unix
  • SnapDrive for Windows
  • SnapManager for Exchange
  • SnapManager for Hyper-V
  • SnapManager for MS SQL
  • SnapManager for Sharepoint
  • Storage Services Connector

Software Versions and Fixes

NetApp's currently available patches are listed below.


Product First Fixed in Release
OnCommand Shift OnCommand Shift has no plans to address this vulnerability. See the EOA announcement for more information.
SnapManager for Oracle https://mysupport.netapp.com/NOW/download/software/snapmanager_oracle_unix/3.4.2/
https://mysupport.netapp.com/NOW/download/software/snapmanager_oracle_win/3.4.2/
OnCommand Unified Manager for 7-Mode (core package) https://mysupport.netapp.com/NOW/download/software/occore_win/5.2.3/
https://mysupport.netapp.com/NOW/download/software/occore_lin/5.2.3/
Active IQ Unified Manager (formerly OnCommand Unified Manager) for Windows 7.3 and above http://mysupport.netapp.com/NOW/download/software/oncommand_um/7.3/
E-Series SANtricity Web Services (REST API) for Web Services Proxy https://mysupport.netapp.com/NOW/download/software/eseries_webservices/2.12/
E-Series SANtricity Storage Manager https://mysupport.netapp.com/NOW/download/software/eseries_santricity/11.42.0X00.0001/
NetApp VASA Provider for Clustered Data ONTAP 6.x NetApp VASA Provider for Clustered Data ONTAP 6.x has no plans to address this vulnerability. See the EOA announcement for more information.
OnCommand Insight https://mysupport.netapp.com/NOW/download/software/sanscreen/7.3.2/
https://mysupport.netapp.com/NOW/download/software/sanscreen_linux/7.3.2/
NetApp VASA Provider for Clustered Data ONTAP 7.2 and above https://mysupport.netapp.com/NOW/download/software/vasa_cdot/7.2/
E-Series SANtricity Management Plug-ins (VMware SRA) E-Series SANtricity Management Plug-ins (VMware SRA) has no plans to address this vulnerability. See the EOA announcement for more information.
NetApp SANtricity Cloud Connector https://mysupport.netapp.com/NOW/download/software/eseries_sant_cloudcon/3.1/
SnapManager for SAP https://mysupport.netapp.com/NOW/download/software/snapmanager_sap_win/3.4.2/
https://mysupport.netapp.com/NOW/download/software/snapmanager_sap_unix/3.4.2/
StorageGRID (formerly StorageGRID Webscale) https://mysupport.netapp.com/NOW/download/software/storagegrid_webscale/11.0.1.3/
E-Series SANtricity Management Plug-ins (VMware vCenter) https://kb.netapp.com/app/answers/answer_view/a_id/1031085

Follow the steps in the Knowledgebase article to update Java.
E-Series SANtricity OS Controller Software 11.x https://mysupport.netapp.com/NOW/download/software/eseries_cfw/11.30.5/
Virtual Storage Console for VMware vSphere 7.2 and above https://mysupport.netapp.com/NOW/download/software/vsc_win/7.2/
E-Series SANtricity Management Plug-ins (VMware vCenter (Linux)) E-Series SANtricity Management Plug-ins (VMware vCenter (Linux)) has no plans to address this vulnerability.
Virtual Storage Console for VMware vSphere 6.x https://mysupport.netapp.com/NOW/download/software/vsc_win/6.2.2/
NetApp Cloud Backup (formerly AltaVault) https://mysupport.netapp.com/NOW/download/software/altavault_phyapp/4.3.2/
Storage Replication Adapter for Clustered Data ONTAP for VMware vSphere 7.2 and above https://mysupport.netapp.com/NOW/download/software/sra_cmode/7.2/
E-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM)) E-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM)) has no plans to address this vulnerability. See the EOA announcement for more information.
StorageGRID9 (9.x and prior) https://kb.netapp.com/app/answers/answer_view/a_id/1031278

Contact technical support for assistance upgrading Java.
Active IQ Unified Manager (formerly OnCommand Unified Manager) for VMware vSphere 9.5 and above https://mysupport.netapp.com/NOW/download/software/oncommand_um/7.3P1/
E-Series SANtricity Management Plug-ins (VMware VASA (Windows)) E-Series SANtricity Management Plug-ins (VMware VASA (Windows)) has no plans to address this vulnerability. See the EOA announcement for more information.
OnCommand Workflow Automation https://mysupport.netapp.com/products/ocwfa/5.0/
Storage Replication Adapter for Clustered Data ONTAP for Windows 7.2 and above https://mysupport.netapp.com/NOW/download/software/sra_cmode/7.2/
NetApp Plug-in for Symantec NetBackup NetApp Plug-in for Symantec NetBackup has no plans to address this vulnerability. See the EOA announcement for more information.

Workarounds

If a product requires JRE but does not include it, please update JRE to a fixed version that aligns with the product requirements.

  • Updating the Java Runtime Environment (JRE) used by SANtricity Storage Manager 11.10 or later
    https://kb.netapp.com/app/answers/answer_view/a_id/1029741
  • Updating the Java Runtime Environment (JRE) used by the following products
    https://kb.netapp.com/app/answers/answer_view/a_id/1031085
    • E-Series/EF-Series SANtricity Management Plug-ins (VMWare SRA)
    • E-Series/EF-Series SANtricity Management Plug-ins (VMWare VASA (Windows))
    • E-Series/EF-Series SANtricity Management Plug-ins (VMWare Vcenter VASA (Linux))
    • E-Series/EF-Series SANtricity Management Plug-ins (VMWare Vcenter VASA (Windows))

Beginning with OnCommand Workflow Automation for Linux & Windows 4.2, OnCommand Unified Manager for Linux & Windows 7.2, NetApp Service Level Manager 1.0, and OnCommand API Services 1.2 the Java software libraries can be upgraded as specified in the product documentation. For assistance with the upgrade, please consult technical support.

Obtaining Software Fixes

Software fixes will be made available through the NetApp Support website in the Software Download section.

https://mysupport.netapp.com/site/downloads/

Customers who do not have access to the Support website should contact Technical Support at the number below to obtain the patches.

Contact Information

Check http://mysupport.netapp.com for further updates.
For questions, contact NetApp at:

Technical Support
mysupport.netapp.com
1 888 4 NETAPP (1 888 463 8277) (U.S. and Canada)
+00 800 44 638277 (EMEA/Europe)
+800 800 80 800 (Asia/Pacific)

Status of This Notice

Final.

This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

This advisory is posted at the following link:
https://security.netapp.com/advisory/NTAP-20180117-0001

Revision History

Revision # Date Comments
1.0 20180117 Initial Public Release
2.0 20180118 E-Series SANtricity Cloud Connector and E-Series SANtricity Web Services (REST API) moved to Affected Products
3.0 20180119 OnCommand Unified Manager for Windows for 7.2 and above and OnCommand Unified Manager for VMware vSphere for 7.2 and above moved to Affected Products
4.0 20180123 Updated Workarounds, OnCommand Workflow Automation, E-Series SANtricity Management Plug-ins (VMware vCenter (Linux)), E-Series SANtricity Management Plug-ins (VMware vCenter (Windows)),E-Series SANtricity Management Plug-ins (VMware VASA (Windows)), E-Series SANtricity Management Plug-ins (VMware SRA), E-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM)), E-Series SANtricity Storage Manager, E-Series SANtricity OS Controller Software 11.30 and later and OnCommand Unified Manager for 7-mode (core package) moved to Affected Products
5.0 20180124 Virtual Storage Console for VMware vSphere moved to Affected Products, 7-Mode Transition Tool moved to Products Not Affected
6.0 20180201 NetApp VASA Provider for Clustered Data ONTAP 7.0 and above and Storage Replication Adapter for Clustered Data ONTAP 7.0 and above moved to Affected Products
7.0 20180202 NetApp VASA Provider for Clustered Data ONTAP 6.x and Storage Replication Adapter for Clustered Data ONTAP 4.x moved to Affected Products
8.0 20180216 StorageGRID and StorageGRID Webscale moved to Affected Products
9.0 20180221 SnapManager for Oracle and SnapManager for SAP moved to Affected Products
10.0 20180316 NetApp VASA Provider for Clustered Data ONTAP 6.x moved to Won't Fix status
11.0 20180419 Updated Workarounds
12.0 20180420 OnCommand Unified Manager for Windows 7.2 and above added to Software Versions and Fixes
13.0 20180426 OnCommand Insight added to Software Versions and Fixes
14.0 20180501 E-Series SANtricity Storage Manager, E-Series SANtricity Web Services (REST API) for Web Services Proxy and E-Series SANtricity OS Controller Software 11.30 and later added to Software Versions and Fixes
15.0 20180502 E-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM)), E-Series SANtricity Management Plug-ins (VMware SRA), and E-Series SANtricity Management Plug-ins (VMware VASA (Windows)) moved to Won't Fix status
16.0 20180516 Virtual Storage Console for VMware vSphere 6.x added to Software Versions and Fixes
17.0 20180518 NetApp SANtricity Cloud Connector, StorageGRID Webscale added to Software Versions and Fixes
18.0 20180523 OnCommand Unified Manager for VMware vSphere for 7.2 and above added to Software Versions and Fixes
19.0 20180621 OnCommand Unified Manager for 7-Mode (core package) added to Software Versions and Fixes
20.0 20180717 Virtual Storage Console for VMware vSphere 7.0 and above, Storage Replication Adapter for Clustered Data ONTAP for VMware vSphere 4.x and above, NetApp VASA Provider for Clustered Data ONTAP 7.0 and above added to Software Versions and Fixes
21.0 20180914 StorageGRID added to Software Versions and Fixes - the solution requires assistance from technical support
22.0 20181112 NetApp Cloud Backup (formerly AltaVault) added to Software Versions and Fixes
23.0 20190128 SnapManager for SAP, SnapManager for Oracle added to Software Versions and Fixes
24.0 20190208 OnCommand Workflow Automation added to Software Versions and Fixes
25.0 20190318 Storage Replication Adapter for Clustered Data ONTAP for Windows 7.2 and above added to Software Versions and Fixes
26.0 20200123 E-Series SANtricity Management Plug-ins (VMware vCenter) added to Software Versions and Fixes
27.0 20201208 OnCommand Cloud Manager moved to Products Not Affected
28.0 20210105 NetApp Plug-in for Symantec NetBackup moved to Won't Fix status, Final status

This document is provided solely for informational purposes. All information is based upon NetApp’s current knowledge and understanding of the hardware and software products tested by NetApp, and the methodology and assumptions used by NetApp. NetApp is not responsible for any errors or omissions that may be contained herein, and no warranty, representation, or other legal commitment or obligation is being provided by NetApp. © 2017 NetApp, Inc. All rights reserved. No portions of this document may be reproduced without prior written consent of NetApp, Inc.