September 2017 PHP Vulnerabilities in NetApp Products

Summary

Multiple NetApp products use PHP. PHP versions below 7.1.9, 7.0.23 and 5.6.31 are susceptible to vulnerabilities that could lead to a Denial of Service(DoS), arbitrary code execution, bypass of hostname-specific URL checks, information disclosure, server side request forgery or buffer overflow based attacks.

Impact

Successful exploitation of the vulnerabilities could lead to a Denial of Service(DoS), arbitrary code execution, bypass of hostname-specific URL checks, information disclosure, server side request forgery or buffer overflow based attacks.

Vulnerability Scoring Details

CVE Score Vector
CVE-2016-10158 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2016-10159 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2016-10160 9.8 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2016-10161 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2016-10397 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVE-2016-5399 7.8 (HIGH) CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE-2016-5873 9.8 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2016-7478 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2016-7479 9.8 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2016-7480 9.8 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2017-11142 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2017-11143 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2017-11144 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2017-11145 7.5 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVE-2017-11147 9.1 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVE-2017-11362 9.8 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2017-11628 7.8 (HIGH) CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE-2017-12932 9.8 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2017-5340 9.8 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2017-7272 7.4 (HIGH) CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
CVE-2017-7890 6.5 (MEDIUM) CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
CVE-2017-9119 9.8 (CRITICAL) CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation and Public Announcements

NetApp is aware of public discussion of this vulnerability.

Affected Products

  • Clustered Data ONTAP
  • Storage Automation Store

Products Not Affected

  • 7-Mode Transition Tool
  • ATTO FibreBridge
  • AltaVault OST Plug-in
  • AutoSupport, MySupport,support.netapp.com
  • Brocade Fabric Operating System Firmware
  • Brocade Network Advisor Software
  • Brocade Network Operating System Firmware
  • Cloud Control
  • Cluster Network Switch (NetApp CN1610)
  • Clustered Data ONTAP Antivirus Connector
  • Data Migration Appliance DTA2800 (DTA Firmware)
  • Data Migration Appliance DTA2800 (DTA Manager)
  • Data Migration Appliance DTA2800 (DTA Remote CLI)
  • Data Migration Appliance DTA2800 (Space Reclamation Utility)
  • Data ONTAP Edge
  • Data ONTAP operating in 7-Mode
  • E-Series SANtricity Management Plug-ins (Microsoft SQL Server (SSMS))
  • E-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM))
  • E-Series SANtricity Management Plug-ins (Oracle EM)
  • E-Series SANtricity Management Plug-ins (VMware SRA)
  • E-Series SANtricity Management Plug-ins (VMware VASA (Windows))
  • E-Series SANtricity Management Plug-ins (VMware vCenter (Linux))
  • E-Series SANtricity Management Plug-ins (VMware vCenter (Windows))
  • E-Series SANtricity OS Controller Software 11.30 and later
  • E-Series SANtricity OS Controller Software 8.x
  • E-Series SANtricity Storage Manager
  • E-Series SANtricity Web Services (REST API)
  • FAS/AFF System Firmware (BIOS)
  • FAS/V-Series Storage Replication Adapter for 7-Mode Data ONTAP
  • FAS/V-Series Storage Replication Adapter for Clustered Data ONTAP
  • Host Utilities - SAN for ESX
  • Host Utilities - SAN for Unix and Linux
  • Host Utilities - SAN for Windows
  • MetroCluster Tiebreaker for clustered Data ONTAP
  • Multipath I/O (Data ONTAP DSM for Windows MPIO)
  • NetApp AltaVault
  • NetApp Converged Systems Advisor
  • NetApp HCI
  • NetApp Host Agent
  • NetApp Manageability SDK
  • NetApp NFS Plug-in for VMware VAAI
  • NetApp Plug-in for Symantec NetBackup
  • NetApp SANtricity SMI-S Provider
  • NetApp SMI-S Provider
  • NetApp Service Level Manager
  • NetApp Storage Encryption
  • NetApp VASA Provider for Clustered Data ONTAP
  • ONTAP Select Deploy administration utility
  • OnCommand API Services
  • OnCommand Cloud Manager
  • OnCommand Insight
  • OnCommand Plug-in for Microsoft
  • OnCommand Shift
  • OnCommand System Manager
  • OnCommand Unified Manager for 7-mode (core package)
  • OnCommand Unified Manager for Linux for 7.2 and above
  • OnCommand Unified Manager for VMware vSphere for 7.2 and above
  • OnCommand Unified Manager for Windows for 7.2 and above
  • OnCommand Workflow Automation
  • Open Systems SnapVault Agent
  • Perfstat
  • RAID Controller CTS2600 Legacy Engenio
  • Single Mailbox Recovery
  • Snap Creator Framework
  • SnapCenter Server
  • SnapDrive for Unix
  • SnapDrive for Windows
  • SnapManager for Exchange
  • SnapManager for Hyper-V
  • SnapManager for MS SQL
  • SnapManager for Oracle
  • SnapManager for SAP
  • SnapManager for Sharepoint
  • SnapProtect
  • SolidFire Element OS
  • Storage Services Connector
  • StorageGRID
  • StorageGRID Webscale
  • System Setup
  • Virtual Storage Console for VMware vSphere

Software Versions and Fixes

NetApp's currently available patches are listed below.


Workarounds

None at this time.

Obtaining Software Fixes

Software fixes will be made available through the NetApp Support website in the Software Download section.

https://mysupport.netapp.com/NOW/cgi-bin/software/

Customers who do not have access to the Support website should contact Technical Support at the number below to obtain the patches.

Contact Information

Check http://mysupport.netapp.com for further updates.
For questions, contact NetApp at:

Technical Support
mysupport.netapp.com
1 888 4 NETAPP (1 888 463 8277) (U.S. and Canada)
+00 800 44 638277 (EMEA/Europe)
+800 800 80 800 (Asia/Pacific)

Status of This Notice

Interim.

NetApp will continue to update this advisory as additional information becomes available.

This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

This advisory is posted at the following link:
https://security.netapp.com/advisory/NTAP-20180112-0001

Revision History

Revision # Date Comments
1.0 20180112 Initial Public Release

This document is provided solely for informational purposes. All information is based upon NetApp’s current knowledge and understanding of the hardware and software products tested by NetApp, and the methodology and assumptions used by NetApp. NetApp is not responsible for any errors or omissions that may be contained herein, and no warranty, representation, or other legal commitment or obligation is being provided by NetApp. © 2017 NetApp, Inc. All rights reserved. No portions of this document may be reproduced without prior written consent of NetApp, Inc.