CVE-2017-12611 Apache Struts Vulnerability in Multiple NetApp Products

circle-check-alt This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

Summary

Multiple NetApp products incorporate the Apache Struts libraries. Apache Struts versions 2.0.1 through 2.3.33 and 2.5 through 2.5.10 are susceptible to a vulnerability which could result in unauthorized remote code execution.

Impact

Successful exploitation of this vulnerability could result in unauthorized remote code execution.

Vulnerability Scoring Details

CVE Score Vector
8.1 (HIGH) CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation and Public Announcements

NetApp is aware of public discussion of this vulnerability.

References

Affected Products

  • OnCommand Balance

Products Not Affected

  • 7-Mode Transition Tool
  • ATTO FibreBridge
  • Active IQ Unified Manager (formerly OnCommand Unified Manager) for Linux 7.3 and above
  • Active IQ Unified Manager (formerly OnCommand Unified Manager) for VMware vSphere 9.5 and above
  • Active IQ Unified Manager (formerly OnCommand Unified Manager) for Windows 7.3 and above
  • Brocade Fabric Operating System Firmware
  • Brocade Network Advisor Software
  • Clustered Data ONTAP
  • Clustered Data ONTAP Antivirus Connector
  • Data ONTAP operating in 7-Mode
  • E-Series SANtricity Management Plug-ins (VMware vCenter)
  • E-Series SANtricity OS Controller Software 11.x
  • E-Series SANtricity Storage Manager
  • E-Series SANtricity Web Services (REST API) for Web Services Proxy
  • FAS/AFF BIOS
  • Host Utilities - SAN for Linux
  • Host Utilities - SAN for Windows
  • MetroCluster Tiebreaker for clustered Data ONTAP
  • NetApp Cloud Backup (formerly AltaVault)
  • NetApp Cloud Backup OST Plug-in (formerly AltaVault OST Plug-in)
  • NetApp Converged Systems Advisor Agent
  • NetApp HCI Compute Node (Bootstrap OS)
  • NetApp Manageability SDK
  • NetApp NFS Plug-in for VMware VAAI
  • NetApp Plug-in for Symantec NetBackup
  • NetApp SANtricity SMI-S Provider
  • NetApp SMI-S Provider
  • NetApp Service Level Manager
  • NetApp SolidFire & HCI Storage Node (Element Software)
  • NetApp Storage Encryption
  • NetApp VASA Provider for Clustered Data ONTAP 7.2 and above
  • ONTAP Select Deploy administration utility
  • OnCommand API Services
  • OnCommand Cloud Manager
  • OnCommand Insight
  • OnCommand System Manager 9.x
  • OnCommand Unified Manager for 7-Mode (core package)
  • OnCommand Workflow Automation
  • Open Systems SnapVault Agent
  • RAID Controller CTS2600 Legacy Engenio
  • Service Processor
  • Single Mailbox Recovery
  • Snap Creator Framework
  • SnapCenter
  • SnapDrive for Unix
  • SnapDrive for Windows
  • SnapManager for Exchange
  • SnapManager for Hyper-V
  • SnapManager for MS SQL
  • SnapManager for Oracle
  • SnapManager for SAP
  • SnapManager for Sharepoint
  • Storage Replication Adapter for Clustered Data ONTAP for VMware vSphere 7.2 and above
  • Storage Services Connector
  • StorageGRID (formerly StorageGRID Webscale)
  • StorageGRID Webscale NAS Bridge
  • StorageGRID9 (9.x and prior)
  • System Setup
  • Virtual Storage Console for VMware vSphere 7.2 and above

Software Versions and Fixes

NetApp's currently available patches are listed below.


Product First Fixed in Release
OnCommand Balance OnCommand Balance has no plans to address this vulnerability. See the EOA announcement for more information.

Workarounds

None

Obtaining Software Fixes

Software fixes will be made available through the NetApp Support website in the Software Download section.

https://mysupport.netapp.com/site/downloads/

Customers who do not have access to the Support website should contact Technical Support at the number below to obtain the patches.

Contact Information

Check http://mysupport.netapp.com for further updates.
For questions, contact NetApp at:

Technical Support
mysupport.netapp.com
1 888 4 NETAPP (1 888 463 8277) (U.S. and Canada)
+00 800 44 638277 (EMEA/Europe)
+800 800 80 800 (Asia/Pacific)

Status of This Notice

Final.

This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

This advisory is posted at the following link:
https://security.netapp.com/advisory/NTAP-20170911-0001

Revision History

Revision # Date Comments
1.0 20170911 Initial Public Release
2.0 20180119 OnCommand Balance moved to Won't Fix status, Final status

This document is provided solely for informational purposes. All information is based upon NetApp’s current knowledge and understanding of the hardware and software products tested by NetApp, and the methodology and assumptions used by NetApp. NetApp is not responsible for any errors or omissions that may be contained herein, and no warranty, representation, or other legal commitment or obligation is being provided by NetApp. © 2017 NetApp, Inc. All rights reserved. No portions of this document may be reproduced without prior written consent of NetApp, Inc.