January 2015 Java Runtime Environment (JRE) Vulnerabilities in Multiple NetApp Products

circle-check-alt This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

Summary

Multiple NetApp products incorporate the Java Runtime Environment (JRE) software libraries. JRE versions up to 8u31 and 7u75 are susceptible to multiple vulnerabilities, potentially leading to an unauthorized Operating System takeover including arbitrary code execution, a partial denial of service, or unauthorized update, insert or delete access to some Java SE accessible data. This advisory will be updated as additional information becomes available.

Impact

Exploitation of this vulnerability may lead to unauthorized Operating System takeover including arbitrary code execution, a partial denial of service, or unauthorized update, insert or delete access to some Java SE accessible data.

Vulnerability Scoring Details

CVE Score Vector
CVE-2014-3566 3.7 (LOW) AV:N/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2014-6549 8.5 (HIGH) AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C
CVE-2014-6585 2.2 (LOW) AV:N/AC:H/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2014-6587 3.7 (LOW) AV:L/AC:L/Au:S/C:P/I:P/A:P/E:U/RL:U/RC:C
CVE-2014-6591 2.2 (LOW) AV:N/AC:H/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2014-6593 3.4 (LOW) AV:N/AC:H/Au:N/C:P/I:P/A:N/E:U/RL:U/RC:C
CVE-2014-6601 8.5 (HIGH) AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C
CVE-2015-0383 4.6 (MEDIUM) AV:L/AC:M/Au:N/C:N/I:P/A:C/E:U/RL:U/RC:C
CVE-2015-0395 7.9 (HIGH) AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C
CVE-2015-0400 4.3 (MEDIUM) AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2015-0403 5.9 (MEDIUM) AV:L/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C
CVE-2015-0406 4.9 (MEDIUM) AV:N/AC:M/Au:N/C:P/I:N/A:P/E:U/RL:U/RC:C
CVE-2015-0407 4.3 (MEDIUM) AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2015-0408 8.5 (HIGH) AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C
CVE-2015-0410 4.3 (MEDIUM) AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2015-0412 8.5 (HIGH) AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C
CVE-2015-0413 1.6 (LOW) AV:L/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C
CVE-2015-0421 5.9 (MEDIUM) AV:L/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C
CVE-2015-0437 7.9 (HIGH) AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C

Exploitation and Public Announcements

NetApp is aware of public discussion of this vulnerability.

References

Affected Products

  • 7-Mode Transition Tool
  • E-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM))
  • E-Series SANtricity Management Plug-ins (VMware SRA)
  • E-Series SANtricity Management Plug-ins (VMware VASA (Windows))
  • E-Series SANtricity Management Plug-ins (VMware vCenter (Linux))
  • E-Series SANtricity Management Plug-ins (VMware vCenter)
  • E-Series SANtricity Storage Manager
  • E-Series SANtricity Web Services (REST API) for Web Services Proxy
  • MetroCluster Plug-in for vSphere
  • NetApp VASA Provider for Clustered Data ONTAP 7.2 and above
  • NetApp VASA Provider for Data ONTAP operating in 7-Mode
  • OnCommand Balance
  • OnCommand Cloud Manager
  • OnCommand Insight
  • OnCommand Performance Manager (Unified Manager Performance Pkg)
  • OnCommand Report
  • OnCommand Unified Manager Host Package
  • OnCommand Unified Manager for 7-Mode (core package)
  • OnCommand Unified Manager for Clustered Data ONTAP
  • OnCommand Workflow Automation
  • SnapManager for Oracle
  • SnapManager for SAP
  • Virtual Storage Console for VMware vSphere 7.2 and above

Products Not Affected

  • ATTO FibreBridge
  • Brocade Fabric Operating System Firmware
  • Brocade Network Advisor Software
  • Clustered Data ONTAP
  • Clustered Data ONTAP Antivirus Connector
  • Data ONTAP operating in 7-Mode
  • FAS/AFF BIOS
  • Host Utilities - SAN for Linux
  • Host Utilities - SAN for Windows
  • NetApp Cloud Backup (formerly AltaVault)
  • NetApp Manageability SDK
  • NetApp NFS Plug-in for VMware VAAI
  • NetApp Plug-in for Symantec NetBackup
  • NetApp SANtricity SMI-S Provider
  • NetApp SMI-S Provider
  • NetApp Storage Encryption
  • OnCommand System Manager 9.x
  • Open Systems SnapVault Agent
  • RAID Controller CTS2600 Legacy Engenio
  • RapidData Migration Solution
  • Service Processor
  • Single Mailbox Recovery
  • Snap Creator Framework
  • SnapDrive for Unix
  • SnapDrive for Windows
  • SnapManager for Exchange
  • SnapManager for Hyper-V
  • SnapManager for MS SQL
  • SnapManager for Sharepoint
  • Storage Replication Adapter for Clustered Data ONTAP for VMware vSphere 7.2 and above
  • Storage Services Connector
  • StorageGRID (formerly StorageGRID Webscale)
  • StorageGRID9 (9.x and prior)
  • System Setup

Software Versions and Fixes

NetApp's currently available patches are listed below.


Product First Fixed in Release
SnapManager for Oracle http://mysupport.netapp.com/NOW/download/software/snapmanager_oracle_unix/3.4/
http://mysupport.netapp.com/NOW/download/software/snapmanager_oracle_win/3.4/
OnCommand Cloud Manager http://mysupport.netapp.com/NOW/download/software/oncommand_cloud/1.1/
OnCommand Unified Manager for Clustered Data ONTAP http://mysupport.netapp.com/NOW/download/software/oncommand_cdot/6.2/
http://mysupport.netapp.com/NOW/download/software/oncommand_cdot_lin/6.2/
E-Series SANtricity Storage Manager http://mysupport.netapp.com/NOW/download/software/eseries_santricity/11.20.0X00.0015/
E-Series SANtricity Management Plug-ins (VMware vCenter (Linux)) http://mysupport.netapp.com/NOW/download/software/eseries_vmware_vcenter/3.00.X000.0021/
NetApp VASA Provider for Clustered Data ONTAP 7.2 and above http://mysupport.netapp.com/NOW/download/software/vasa_cdot/6.2/
E-Series SANtricity Management Plug-ins (VMware SRA) https://kb.netapp.com/Advice_and_Troubleshooting/Data_Infrastructure_Management/E-Series_SANtricity_Management_Software/How_to_patch_Java_JRE_versions_for_older_SANtricity_Management_Plug-ins_and_APIs
SnapManager for SAP http://mysupport.netapp.com/NOW/download/software/snapmanager_sap_unix/3.4/
http://mysupport.netapp.com/NOW/download/software/snapmanager_sap_win/3.4/
OnCommand Report OnCommand Report has no plans to address this vulnerability. See the EOA announcement for more information.
E-Series SANtricity Management Plug-ins (VMware vCenter) https://kb.netapp.com/Advice_and_Troubleshooting/Data_Infrastructure_Management/E-Series_SANtricity_Management_Software/How_to_patch_Java_JRE_versions_for_older_SANtricity_Management_Plug-ins_and_APIs
OnCommand Unified Manager for 7-Mode (core package) https://mysupport.netapp.com/NOW/download/software/occore_lin/5.2.2/
https://mysupport.netapp.com/NOW/download/software/occore_win/5.2.2/
Virtual Storage Console for VMware vSphere 7.2 and above http://mysupport.netapp.com/NOW/download/software/vsc_win/6.2/
OnCommand Performance Manager (Unified Manager Performance Pkg) http://mysupport.netapp.com/NOW/download/software/oncommand_pm/1.1/
http://mysupport.netapp.com/NOW/download/software/oncommand_pm_linux/1.1/
OnCommand Insight http://mysupport.netapp.com/NOW/download/software/sanscreen/7.0.3/
OnCommand Unified Manager Host Package OnCommand Unified Manager Host Package has no plans to address this vulnerability. See the EOA announcement for more information.
E-Series SANtricity Web Services (REST API) for Web Services Proxy https://mysupport.netapp.com/NOW/download/software/eseries_webservices/1.40.X000.0009/
7-Mode Transition Tool http://mysupport.netapp.com/NOW/download/software/ntap_7mtt/2.1/
NetApp VASA Provider for Data ONTAP operating in 7-Mode NetApp VASA Provider for Data ONTAP operating in 7-Mode has no plans to address this vulnerability. See the EOA announcement for more information.
E-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM)) https://mysupport.netapp.com/NOW/download/software/eseries_scom/3.00.0004.3000/
E-Series SANtricity Management Plug-ins (VMware VASA (Windows)) https://kb.netapp.com/Advice_and_Troubleshooting/Data_Infrastructure_Management/E-Series_SANtricity_Management_Software/How_to_patch_Java_JRE_versions_for_older_SANtricity_Management_Plug-ins_and_APIs
OnCommand Workflow Automation http://mysupport.netapp.com/NOW/download/software/ocwfa/3.0/
OnCommand Balance http://mysupport.netapp.com/NOW/download/software/oncommand_ib/4.2P4/
MetroCluster Plug-in for vSphere MetroCluster Plug-in for vSphere has no plans to address this vulnerability. See the EOA announcement for more information.

Workarounds

If a product requires JRE but does not include it, please update JRE to a fixed version that aligns with the product requirements.

Obtaining Software Fixes

Software fixes will be made available through the NetApp Support website in the Software Download section.

https://mysupport.netapp.com/site/downloads/

Customers who do not have access to the Support website should contact Technical Support at the number below to obtain the patches.

Contact Information

Check http://mysupport.netapp.com for further updates.
For questions, contact NetApp at:

Technical Support
mysupport.netapp.com
1 888 4 NETAPP (1 888 463 8277) (U.S. and Canada)
+00 800 44 638277 (EMEA/Europe)
+800 800 80 800 (Asia/Pacific)

Status of This Notice

Final.

This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

This advisory is posted at the following link:
https://security.netapp.com/advisory/NTAP-20150126-0001

Revision History

Revision # Date Comments
1.0 20150126 Initial Public Release
2.0 20150130 Updated Affected Products, Products With Revised Vulnerability Status, & Workarounds
3.0 20150202 Updated Affected Products
4.0 20150206 Updated Affected Products
5.0 20150209 Updated Affected Products
6.0 20150210 Updated Affected Products
7.0 20150306 Updated Software Versions and Fixes
8.0 20150316 Updated Affected Products
9.0 20150326 Updated Software Versions and Fixes
10.0 20150409 Updated Software Versions and Fixes
11.0 20150514 Updated Affected Products, Products Not Affected, & Software Versions and Fixes
12.0 20150910 E-Series/EF-Series SANtricity Storage Manager added to Software Versions and Fixes
13.0 20150916 7-Mode Transition Tool, OnCommand Unified Manager Host Package & OnCommand Report added to Software Versions and Fixes, RapidData Migration Solution removed due to EOL
14.0 20151202 SnapManager for Oracle (SMO) and SnapManager for SAP (SMSAP) added to Software Versions and Fixes
15.0 20160126 MetroCluster Plug-in for vSphere removed due to EOA
16.0 20160308 Virtual Storage Console for Vmware vSphere, NetApp VASA Provider for Clustered Data ONTAP added to Software Versions and Fixes
17.0 20160823 Removing NetApp Management Console from Affected Products as it is tracked under OnCommand Unified Manager Core Package (5.x) 7-Mode
18.0 20160825 E-Series/EF-Series SANtricity Management Plug-ins (WebServices) added to Software Versions and Fixes
19.0 20160901 E-Series/EF-Series SANtricity Management Plug-ins (Microsoft System Center (SCOM)) added to Software Versions and Fixes
20.0 20160913 E-Series/EF-Series SANtricity Management Plug-ins (VMWare SRA), E-Series/EF-Series SANtricity Management Plug-ins (VMWare VASA (Windows)), E-Series/EF-Series SANtricity Management Plug-ins (VMWare Vcenter VASA (Linux)), E-Series/EF-Series SANtricity Management Plug-ins (VMWare Vcenter VASA (Windows)) added to Workarounds
21.0 20161013 E-Series/EF-Series SANtricity Management Plug-ins (VMWare Vcenter VASA (Linux)), E-Series/EF-Series SANtricity Management Plug-ins (VMWare Vcenter VASA (Windows)) added to Software Versions and Fixes
22.0 20170322 OnCommand Unified Manager Core Package 5.x added to Software Versions and Fixes, Final Status

This document is provided solely for informational purposes. All information is based upon NetApp’s current knowledge and understanding of the hardware and software products tested by NetApp, and the methodology and assumptions used by NetApp. NetApp is not responsible for any errors or omissions that may be contained herein, and no warranty, representation, or other legal commitment or obligation is being provided by NetApp. © 2017 NetApp, Inc. All rights reserved. No portions of this document may be reproduced without prior written consent of NetApp, Inc.