October 2014 Oracle MySQL vulnerabilities in Multiple NetApp Products

circle-check-alt This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

Summary

Multiple NetApp products incorporate Oracle MySQL. MySQL versions up to 5.6.20 and 5.5.39 are susceptible to multiple vulnerabilities, which are addressed in versions 5.6.21 and 5.5.40. This advisory will be updated as additional information becomes available.

Impact

Exploitation of this vulnerability may lead to unauthorized takeover of MySQL Server possibly including arbitrary code execution within the MySQL Server, unauthorized ability to cause a hang or frequently repeatable crash (partial or complete DOS) of MySQL Server or the Operating System, and unauthorized read, update, insert or delete access to a subset or all MySQL Server accessible data.

Vulnerability Scoring Details

CVE Score Vector
CVE-2012-5615 4.3 (MEDIUM) AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2014-0224 5.8 (MEDIUM) AV:N/AC:M/Au:N/C:P/I:P/A:P/E:U/RL:U/RC:C
CVE-2014-4274 3.5 (LOW) AV:L/AC:M/Au:S/C:P/I:P/A:P/E:U/RL:U/RC:C
CVE-2014-4287 3.4 (LOW) AV:N/AC:L/Au:S/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6463 2.8 (LOW) AV:N/AC:L/Au:M/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6464 3.4 (LOW) AV:N/AC:L/Au:S/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6469 5.8 (MEDIUM) AV:N/AC:L/Au:S/C:N/I:N/A:C/E:U/RL:U/RC:C
CVE-2014-6474 3.0 (LOW) AV:N/AC:M/Au:S/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6478 4.3 (MEDIUM) AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2014-6484 3.4 (LOW) AV:N/AC:L/Au:S/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6489 4.7 (MEDIUM) AV:N/AC:L/Au:S/C:N/I:P/A:P/E:U/RL:U/RC:C
CVE-2014-6491 6.4 (MEDIUM) AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:U/RC:C
CVE-2014-6494 3.7 (LOW) AV:N/AC:M/Au:N/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6495 3.7 (LOW) AV:N/AC:M/Au:N/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6496 3.7 (LOW) AV:N/AC:M/Au:N/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6500 6.4 (MEDIUM) AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:U/RC:C
CVE-2014-6505 3.4 (LOW) AV:N/AC:L/Au:S/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6507 6.8 (MEDIUM) AV:N/AC:L/Au:S/C:P/I:P/A:C/E:U/RL:U/RC:C
CVE-2014-6520 3.4 (LOW) AV:N/AC:L/Au:S/C:N/I:N/A:P/E:U/RL:U/RC:C
CVE-2014-6530 5.5 (MEDIUM) AV:N/AC:L/Au:S/C:P/I:P/A:P/E:U/RL:ND/RC:C
CVE-2014-6551 1.8 (LOW) AV:L/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2014-6555 5.5 (MEDIUM) AV:N/AC:L/Au:S/C:P/I:P/A:P/E:U/RL:U/RC:C
CVE-2014-6559 3.7 (LOW) AV:N/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C
CVE-2014-6564 3.4 (LOW) AV:N/AC:L/Au:S/C:N/I:N/A:P/E:U/RL:U/RC:C

Exploitation and Public Announcements

NetApp is aware of public discussion of this vulnerability.

References

Affected Products

  • OnCommand Cloud Manager
  • OnCommand Insight
  • OnCommand Performance Manager (Unified Manager Performance Pkg)
  • OnCommand Unified Manager for Clustered Data ONTAP
  • OnCommand Workflow Automation
  • StorageGRID Webscale

Products Not Affected

  • 7-Mode Transition Tool
  • ATTO FibreBridge
  • AutoSupport, MySupport,support.netapp.com
  • Brocade Fabric Operating System Firmware
  • Brocade Network Advisor Software
  • Brocade Network Operating System Firmware
  • Cluster Network Switch (NetApp CN1610)
  • Clustered Data ONTAP
  • Clustered Data ONTAP Antivirus Connector
  • Data ONTAP Edge
  • Data ONTAP operating in 7-Mode
  • E-Series SANtricity Management Plug-ins (VMware vCenter)
  • E-Series SANtricity OS Controller Software 8.x
  • E-Series SANtricity Storage Manager
  • E-Series SANtricity Web Services (REST API) for Web Services Proxy
  • FAS/AFF System Firmware
  • Host Utilities - SAN for ESX
  • Host Utilities - SAN for Unix and Linux
  • Host Utilities - SAN for Windows
  • Multipath I/O (Data ONTAP DSM for Windows MPIO)
  • NetApp Cloud Backup
  • NetApp Host Agent
  • NetApp Manageability SDK
  • NetApp NFS Plug-in for VMware VAAI
  • NetApp Plug-in for Symantec NetBackup
  • NetApp SANtricity SMI-S Provider
  • NetApp SMI-S Provider
  • NetApp Storage Encryption
  • NetApp VASA Provider for Clustered Data ONTAP 7.0 and above
  • OnCommand Balance
  • OnCommand Plug-in for Microsoft
  • OnCommand System Manager
  • OnCommand Unified Manager for 7-Mode (core package)
  • Open Systems SnapVault Agent
  • RAID Controller CTS2600 Legacy Engenio
  • Service Processor
  • Single Mailbox Recovery
  • Snap Creator Framework
  • SnapDrive for Unix
  • SnapDrive for Windows
  • SnapManager for Exchange
  • SnapManager for Hyper-V
  • SnapManager for MS SQL
  • SnapManager for Oracle
  • SnapManager for SAP
  • SnapManager for Sharepoint
  • SnapProtect
  • Storage Replication Adapter for Clustered Data ONTAP for VMware vSphere 4.x and above
  • Storage Services Connector
  • StorageGRID
  • System Setup
  • Virtual Storage Console for VMware vSphere 7.0 and above

Software Versions and Fixes

NetApp's currently available patches are listed below.


Workarounds

None.

Obtaining Software Fixes

Software fixes will be made available through the NetApp Support website in the Software Download section.

https://mysupport.netapp.com/NOW/cgi-bin/software/

Customers who do not have access to the Support website should contact Technical Support at the number below to obtain the patches.

Contact Information

Check http://mysupport.netapp.com for further updates.
For questions, contact NetApp at:

Technical Support
mysupport.netapp.com
1 888 4 NETAPP (1 888 463 8277) (U.S. and Canada)
+00 800 44 638277 (EMEA/Europe)
+800 800 80 800 (Asia/Pacific)

Status of This Notice

Final.

This advisory should be considered the single source of current, up-to-date, authorized and accurate information from NetApp.

This advisory is posted at the following link:
https://security.netapp.com/advisory/NTAP-20141119-0001

Revision History

Revision # Date Comments
1.0 20141119 Initial Release
2.0 20141119 Publish externally
3.0 20141121 Formatting; updated Products Not Affected
4.0 20141211 Updated Affected Products
5.0 20150123 Formatting edits to align with other advisory documents; updated Affected Products
6.0 20150213 Updated Software Versions and Fixes
7.0 20150326 Updated Software Versions and Fixes
8.0 20150514 Updated Software Versions and Fixes
9.0 20150625 Updated Affected Products & Software Versions and Fixes
10.0 20180731 StoraqeGRID moved to Products Not Affected, Final status

This document is provided solely for informational purposes. All information is based upon NetApp’s current knowledge and understanding of the hardware and software products tested by NetApp, and the methodology and assumptions used by NetApp. NetApp is not responsible for any errors or omissions that may be contained herein, and no warranty, representation, or other legal commitment or obligation is being provided by NetApp. © 2017 NetApp, Inc. All rights reserved. No portions of this document may be reproduced without prior written consent of NetApp, Inc.